Challenges with static ip

Hi folks,

Currently we installed Gibbon in a rather unusual way. It is installed offline and locally due to our unreliable internet connection. This solution works significantly better for us.

Unfortunately we do have challenges due to the fact that the ip address is hardcoded in the database table settings and corresponds to the server ip. Our network and router setup is a little complex and we use port forwarding in some cases. If traffic is forwarded from one subnet to another through port forwarding Gibbon fails because the url contains the static ip address, which is not directly accessible from the other subnet.

All other services work just fine because ip hardcoding is simply not used I guess.

I’m sorry if the description sounds a bit weird and unclear. Please ask if you need more info.

Is there a way out?

Kind regards,

Hi Roman, this is an interesting case. Can you assign a local domain name, instead of using IP addresses? Ross.

Hi Ross,

I haven’t tried your idea yet but did further investigations.

My guess was somehow right and the issue had to do with setting an ip address in field absoluteURL in gibbonSettings.

I run different versions of Gibbon inside of sub folders, e.g.

It seems that changing the field entry of absolute URL from ‘’ to ‘…/gibbon123’ works just fine.

Any thoughts on this fix?

Can this really work throughout Gibbon or have I missed something?

Kind regards,

Hi Roman,

Hmmm, that is interesting, and something I’ve never considered. I would guess that will break down somewhere along the line, but perhaps not. You can always test a wide range of actions and pages within Gibbon and let us know what you find.

Creative thinking…I like it!


Hi Ross,

Yeah, it’s a little weird. Anyway, since there was no objection from your side, I tested the new settings on the productive system. So far, things work fine. The entry in field absoluteURL in gibbonSettings without sub folder is simply ‘…’.

This coming Monday, I’ll really know if this works. That’s when school will resume and the various Gibbon modules will be used by various users.

I’ll report back if things go wrong.

Kind regards,

I am curious how this has evolved> @meierrom can you give an update how things went?


Using ‘…’ didn’t work for us! Form submits worked but resulted in an ugly error message.

We changed from ‘…’ to ‘…/…’. This works perfectly so far.

Kind regards,