All Roles NOT Setting up by any way import/Query Builder

Respected Admin/Sandra,
Very warm wishes for you
We have formally launched Gibbon for production for our School and Also Imported Students and Staff Information Using Data Admin Module But
None is able to Login Because of ALL ROLES is NOT Setting up.
We tried to set ALL ROLES by Following Query
UPDATE gibbonPerson SET gibbonRoleIDAll=gibbonRoleIDPrimary WHERE gibbonRoleIDAll IS NULL OR gibbonRoleIDAll = ‘’;

but It says
Your query contains the following illegal term(s), and so cannot be run: UPDATE, UPDATE.
We also do many tries by using Data Admin Import by putting Student/Std in OtherRoles but it also NOT Working

Please Provide us a solution as early as possible because we have launched Gibbon and Manually Setting ALL ROLES One by one is difficult and So much time Consuming.

Looking forward for an early resonse.
Have a Nice Time

Query Builder is designed to prevent queries that will modify the database. To run the UPDATE query you’ll need to do so directly in MySQL. This can be done from the command line if you’re familiar with accessing the database that way, or with a database tool such as PHPMyAdmin, Sequel Pro, etc. If your system uses a control panel (CPanel, Plesk, etc.) then PHPMyAdmin often comes pre-installed.

Hope this helps! I’ve since updated Data Admin to make the All Roles field required, hopefully preventing this error in the future.

Respected Sandra,
Thank you so much for you quick help . It worked actually when I browse the GibbonPerson table, RoleIDAll was not NULL It was 2 instead of 002 and 3 instead of 003. So I run the query
UPDATE gibbonPerson SET gibbonRoleIDAll=‘003’ WHERE gibbonRoleIDAll IS NULL OR gibbonRoleIDAll = ‘3’;


UPDATE gibbonPerson SET gibbonRoleIDAll=‘002’ WHERE gibbonRoleIDAll = ‘3’;

It worked perfectly fine.

We are grateful To Intelligent Sandra for helping us from all of our team.

Warm wishes
Have a great time.

Best Regards,
Ghulam Abbas

Ah, glad to hear it worked! I’ll double check the importer to see if there’s any reason it may have misplaced those 00’s.