After cloning the installation login fails only for Administrator user

Hi Sandra,
I hope you are doing well!

I need to replicate the installation I already have, for a second school (in fact a branch of the original school)
I need to use the same server for that purpuse.
I followed Template for multiple sites - #2 by achief, so what I did was:

  1. Copied all the installation files under /var/www/html/gibbon.local (my current installation, as I need mostly all the same configurartion) to another directory called gibbbon.pocitos under /var/www/html/
  2. Modified the php.config like mentioned (I left everything the same except the database GUID for which I modified a few characters like suggested)
    So, same user, same password, different path, different database name, different guid for the database.
  3. Modified the base path and base url to match gibbon.someothername
  4. Tried to log in with a regular user (I tried a couple of them) and … it worked!!!
  5. Now … I try to log in with my user (the Administrator) and CRASH …

I did my research, created a new user with several roles, including Administrator, but for the primary role I used another role, not the Administrator. In this case the user was able to log in.
After that I set the primary role for that user to Administrator, and pummm… CRASH again.
So, this is as far as I could narrow down the problem.

This is probably a subtlety I’m incapable of tracing on the code side. So I have no clue of where to look to or what to look for.
Your help will be much appreciated!!!

This is the error message displayed on screen: (which obviously does not reveal the nature of the problem)



Something has gone wrong: the Gibbons have escaped!
An error has occurred. This could mean a number of different things, but generally indicates that you have a misspelt address, or are trying to access a page that you are not permitted to access. If you cannot solve this problem by retyping the address, or through other means, please contact your system administrator."

Ah, in case it is useful I’m in version 24.

Thank you very much!!!
Warm regards!!

I’m adding additional infomation to the case.
Although not having the Administrator role as main role allows the user to log in, once logged in if it tries to change from whatever role he is in to Administrator, it fails with the same error. That doesn’t happen if he changes to another role different from Administrator.

Thank you!!

Hi Sandra,
Well, after hours of intuitive debugging (that means reading different php files and trying to guess what they were doing, because I have no tools no knowledge to do proper php debugging), and also reading many other posts in the forum, and also some “crying in the rain” :slight_smile:, some sort of dimm light turned on, and I checked php logs, (which at first I didn’t know where they were, but finally I found them), apparently the problem was that some part of the code inside some process was unable to write to some obscure cache folder or file hidden many levels below sight.
So, I changed the permissions on that folder and it started working.
Too painful for my soul!! :frowning: , I feel sad for myself. I should know php programming but I’m sure you understand if I tell you I find no time to engage in that quest.

Well, anyway … problem solved.

1 Like