Active Module Not Showing in Menu

Hi, I’ve been working on this system for some days now trying to fit to our needs. I’ve had encountered issues and they were resolved. Two major things happened before:

Problem: Locally, I’ve change location the location of the system and so I wasn’t able to access the system.
Solution: So, I accessed the db gibbonsetting and changed the absolute url. Somehow, it worked except for the images I have already uploaded, I had to reupload the images specially in the free learning module.

Problem: I tried setting up the user permissions, upon saving the changes, for some reason I felt it was not successful as my administrator account seemed to lost all user admin, school admin ans system admin features.
Diagnosis: I believe it was truncated. I checked my php.ini but the line max_input_vars=3000 is already 3000
Solution: Accessed my db table gibbonpermission and deleted it. I had to reupload my backup db table gibbon permission.

Now, I don’t know if the previous issues has something to do with my problem on modules upon reactivation won’t show on the menu. Existing module menu like free learning somehow works fine. I deactivated and reactivated free learning, and it showed in the menu. For some reasons, the module I have deactivated probably before the 2 problems mentioned above happened. I suspect it has something to do with url?

I tried to install new extension modules, and it worked fine. I can activate and reactivate them with no problem. The deactivated modules before the 2 problems happened seemed unable to show in the menu upon reactivation.

Solution I’ve tried.

  1. deleting the the modules in the module folder. You’ll get a notification that the module present in the db has been deleted. So I pasted the modules again and tried to reactivate them. Somehow, it still wont show in the menu

Anyone who have had the same issue before?

Found the cause of problem > values in the gibbonpermission table.

Solution as of the moment: I had to load the default gibbonpermission table values. Thereafter, I had to set the role permissions again in the interface.

Glad to hear you got it resolved. Any thoughts on what might have caused this issue? It is not a known issue for us. Ross.

I am not sure what caused the problem. Got messed up when I tried updating the user permissions even if I have already set max_input_vars=3000. So i had to import the default permission values in the database.

Hi betasystem101,

I’ve noticed if you deactivate a module, and then update permissions system-wide using Manage Permissions, then the deactivated module’s permissions will have been removed. One reason this happens is using the full-page submits permissions for only the active modules. A way to avoid this is to change permissions per module, using the drop-down filter at the top. I tend to do this, because it also avoid the max_input_vars issue because there’s many less permissions per module than changing the whole system in one submit.

Seems likely. Thank you @ross for the tip using the drop-down.