508 Error !

Hi guys !

I have been using gibbon for learning during the lockdown (since March) without any issues. However for past 2 weeks this new problem of “Entry Process limit reached” has started. I have done a control test on this. It happens whenever about 20-25 students login at the same time. (Go Daddy allots Entry Process limit=125).
I am really not savvy enough to switch to VPS, so I have upgraded to the topmost Linux shared hosting plan. I have only gibbon installed on the domain.
Google says this:

  1. I don’t know how to do any of these. Advice :# ?
  2. I have reduced the session time to 5 minutes. Is there a way to ensure that the person logs out as soon as they leave the page?
  3. Should I/is there a way, to “cache” the pages?
  4. I have not upgraded to the new PhP version (should I?)
  5. Any suggestions? (I know this is going to happen again this evening as the language teacher has scheduled a test).


It seems I did NOT change the session time (I only changed the session duration in the index file). Does this seem the correct way?


I have added expiry to images :# (I reduced the banner size also but it seems it only changed the size in the login page).

Managed to improve my scores a bit by activating the cache and reducing the banner size . No googling the other yellow things.

Hi flygye12,

There is also a notification ajax script that is running in the background for every user, disabling this or reducing it’s intervals may help here. You can find it in the src/UI/Components/Header.php file, lines 151-162.

Hi Sandra !

I found the file you have mentioned. I can’t figure out how to disable it
But shouldn’t I increase the notification refresh interval instead of reducing it?

Right yep, I was thinking “reduce the frequency”. You could turn it down to 5 minutes, or perhaps disable it completely, depending on your needs.