resources module won't work

Hi. We have used gibbon for a couple of years, but not the resource module, so i am no sure if it worked before i updateted.
But now it says that the gibbons have escaped, and is set as an orphaned module in manage modules, and I have no idea how to fix it…

I suspect this is related to that fact that a few Gibbon versions back, the resources module has been removed and integrated into the planner module. Can you post the url?

Yes, that seems to be the problem… but how do i fix it?

Where are you seeing the link? Is it possible that you upgraded to a newer version of Gibbon, uploading the new files, but then not updating the database? The symptoms you are seeing would fit this.

Did you get to this link from one of the menus in Gibbon? Thanks, Ross.

Did you get to this link from one of the menus in Gibbon? Thanks, Ross.


What version of Gibbon are you using?
Can you be more specific about the link? Where exactly did you click to get the link you pasted above?

We run v. 19.

when i hover on this link from homescreen: Planner → Resources, the link it links to is This is also the link that appears in the adressfield when i click on it. Then it says: oh no the gibbons have escaped
if i write inn the adress directly in the adressfield it says that i do not have accsess to this action.

btw we have used gibbon since v. 16 or so, and we have updatet the versions since that.
PS: very happy with gibbon :slight_smile:

Hi Sanne87, that is very odd indeed. We moved Resources from its own module to Planner in v15, and so your install should never had it in resources. If you look at this file, line 614 is the change that would have applied to a v14 system being updated to v15 or higher.

At any rate, if you can run this line on your data server now, that should solve the issue.

Please just change ;end at the end of the line to ; and it should run fine.

Looking at the current version of Gibbon, the installer definitely puts Resources in Planner. All very odd!

Glad to hear that you are happy with Gibbon : )


thank u! :smiley: now it works :smile:

It might be we installed an olde rversion also, i don’t remember… I. think I installed the latest version of gibbon in 2015 or 16… i use it throug docker, maybe that has something to do with it?