Problems with address field

Our registrar is trying to update addresses and remove leavers etc. When she set someone to “leaver” she got the message that Address 1 cannot be more than 30 characters long, even though it had been added without problem the previous year. Is there a way to allow more characters? We are running V16.01 as it will not let us update the database from V14 in order to complete the system update…

Hello, it sounds like these two issues may be related. In v18.0.01 (the latest stable), the length of Address 1 is 255 characters. If you are running v16.0.01 code with v14 database, you’ll definitely get some odd errors. What exactly is preventing the upgrade? Thanks, Ross.

When I try to update the database I get the following error messages. (apologies for the length!)

Hello again,

It looks like the update has already been run, which is odd. To confirm this, can you please check the result of the final database update command in v18.0.00:

UPDATE gibbonAction SET name=‘Manage Custom Fields’ WHERE name=‘Manage User Custom Fields’ AND gibbonModuleID=(SELECT gibbonModuleID FROM gibbonModule WHERE name=‘User Admin’);end

If you look in table gibbonAction, do you see an action named Manage Custom Fields or one called Manage User Custom Fields.

If it is the latter, then the database update has run, and we just need to let the database know that it is indeed up to date.

Not sure what might have led to this scenario!



I am currently in V16 and it won’t let me update to V18 at least through the Web portal. I have tried to do the database update before but it has always given errors and (I thought) not completed. Where should I put in the “UPDATE gibbonAction SET name=‘Manage Custom Fields’ WHERE name=‘Manage User Custom Fields’ AND gibbonModuleID=(SELECT gibbonModuleID FROM gibbonModule WHERE name=‘User Admin’);end” command? In the command line of the server or through the portal? many thanks…

The easiest way is probably to use the sql tab in phpMyAdmin :slight_smile:

Hello, if you run that command, you won’t know if the upgrade has been completed already or not. So, first job, using phpMyAdmin or another SQL client, is to check the gibbonAction table, and see if the action is called “Manage Custom Fields” (database already upgraded) or “Manage User Custom Fields” (database not yet upgraded). Let us know the result. Ross.

Hi Ross, I have just installed myphpadmin and have got into the admin portal. I am not a mysql expert at all. How do I check the status of the GibbonAction table? this is what the databases tab shows:

If you click on the gibbon table (or gibbon_db, depending on how you set it up, you can check your /config.php file in the Gibbon installation to find out which), you should see a list of database tables. Find the table gibbonAction (often at the top of the list), and use the Search function to search the name field for the value “Manage Custom Fields”. Does it give 1 result? If so, the database is upgraded. If you find a result for “Manage User Custom Fields”, then it is not. Good luck! Ross.

I did not find a result for “Manage Custom Fields”, just “Manage User Custom Fields” so I guess it is not updated. What is the next step? Thank you…

If possible I need to finish updating to the latest version soon so that I can use the “Meet the Teacher” add on which uses V18.

I think, the “Meet the Teacher” add on is working with v17 as well. :slight_smile:

Alas, I am still stuck on v16!

Hi sdbaldwin,

It looks like from the PDF you’ve attached that the v16 update has run (possibly more than once). To start, now that you have phpMyAdmin, once you login to your database look for the gibbonSetting table, use search to find the entry named Version. If this says 14 or less, change it to 16.0.00 to ensure your database matches your code version.

From there, backup your database and Gibbon install, and perform the v18.0.01 update by downloading the files and uploading them to your server.

Now, when you visit the System Admin > Update page you should see the option to upgrade the database from v16.0.00 to v18.0.01. Click update and hopefully all goes well. If not, save a copy of your errors (and share it here), but don’t re-run the update.

Hope this helps!

Thank you Sandra, the database update has gone through! I can’t get the update to 18.0.01 to work though. Where does it need to go on the server so that I get prompted to update and taken through the process. I had a go at using the command line but I don’t think my config is quite the same. I can use wget and unzip but gibbon doesn’t find the update, I am probably putting it in the wrong directory.

Do you have FTP access? Rather than command line, sometimes FTP can be more straight forward. You would download the latest version, unzip it locally, then upload the contents of the unzipped folder to your server to replace the existing install. This is similar to a WordPress update, if you’re familiar with those.

I have not set up FTP access yet but I can get into the server directly. I have run the wget command and unzipped it so 18.0.1 is in my home folder. I just need to know where to move it to so that the semi-automatic update detects it and prompts me to update.

This is my directory, I know this is a stupid question but I can’t get my head round it. Where do I need to put the 18.0.01 folder to trigger the upgrade?

Many thanks…

No problem. The contents of the 18.0.01 folder need to be copied into that folder (your root Gibbon folder), so that they overwrite any of the files that have changed. Then when you go to Update it should detect the new version.

So, the folder I screen shot, I just have it in there in a folder at the moment, correct?