Pictures are not working in V23

Hi Team Gibbon,
When I upload pictures from manage users , It’s uploaded successfully but not showing up nor it’s working anywhere it must show.

Hi Ghulam, are you able to email us as sample image on so that we can test this out? I recall testing user image uploads as part of the pre-release tests and it worked fine. Testing with one of your images will definitely help us learn more. Ross

Hi @admin I have emailed you images on

Hi Ghulam, thanks for sharing those images, which we have received. A number of the images are 130 x 130px, which will be too small for user images in Gibbon. The others are 320 x 240px which are too wide. The preferred size is 240 (height) x 320px (width), with Gibbon allowing a little variation as shown below:

Let us know how you get on.


All my pictures were imported okay at the right dimensions.

I also had trouble with pictures that were already in the system after the upgrade to v23. It is possible the problem started after changing folder permissions in response to a security notification that appeared after the upgrade. Did you modify any permission settings before getting those errors?

Thanks @admin ,the issue is not resolved. I have tried many images and also scale them as per requirements but still not working.

The images that were working in previous versions are also not working in V23

Hi Ghulam, if you can email me an unformatted/uncropped image I’ll crop it to the right size, test it on my end, and then send it back to you to see if it works. Ross.

Hi @admin ,
I have emailed you some images. Please check these out. Also please send me some samples of ok Images so that I can test on my install and report back the status.

Hi Ghulam, I’ve resized one of the images and it uploads fine in my v23 installation. I’ve sent it back to you by email as an example you can use. Thanks!

Thanks @admin I tried to upload same image as received by email but the problem is still in place and this image also is not working. I think there is something wrong with my installation. Also I haven’t found error log file in my installation

Hi Ghulam, interesting. Can you upload files elsewhere, such as in the editor in Other > Messenger > New Message? I wonder if this is a file permission issue? Ross

Hi @admin I tried to upload in messenger but it is also not working here.

OK, in which case I would check the permissions for your /uploads folder to make sure that it is writable by your file server. Good luck!

Hi @admin Permissions for /uploads are 750 as follows

Hi Ghulam, this might work, if the owner of the files is the account that runs the web server. In Ubuntu, for example, Apache is run under an account called www-data, and so if this account owns the files, the 750 should work. Ross.

For at least a week I have suspected some of our potential security problems is that the Apache server account doesn’t run as www-data and is therefore requiring permissions for everyone. I’m checking with our data hosting company to confirm that suspicion. Ross, THANKS for this clarification to Ghulam. I suggest adding the 750 recommendation to the install instructions about setting the uploads directory to be writable with a note to ensure the server account is either the owner or group for the directory. It might also help to specify permissions for the contents of the uploads folder. Thanks.

Hi GlennS, thanks for the suggestion. The concern with adding this to the docs is that it’s not a one-size-fits-all approach, as there are so many different ways a server can be setup, especially when there is shared hosting in the mix. We’d be concerned with sharing a file permission solution that works for some users, but could make things less secure for others (by opening up the permissions to group access). This is where a sysadmin would need to discern the best approach for their system.

Sandra and everyone else, I think I finally discovered the problems I was having with the uploads folder permissions. At certain settings, it also gave security warnings about the uploads folder being writable, pictures not being displayed when they had been working prior to the update to v.23.0.0, and some other problems. They were all corrected when I discovered the real problem! Either during the transfer from our office server to an online hosted server, an update to Gibbon software, or our main web site update, the .htaccess file in the Gibbon Root directory had been overwritten. It no longer had the following lines which your Gibbon install directions specify to configure the PHP environment on a hosted server. When these lines were added, problems were solved as that controls much of the server security! Also, thanks for including the check for an improperly configured uploads folder in v.23. I hope this info helps others as confused as I was.
php_flag register_globals off
Options -Indexes
php_value max_input_vars 5000
php_value error_reporting = E_ALL & ~E_NOTICE
php_value allow_url_fopen=On