House Points module v1.4.01 generates errors.

House Points module v1.4.01 generates errors. Parents can’t log in till I uninstall the module.

[proxy_fcgi:error] [pid 29842:tid 140425490851584] [client xx.xx.xx.xx:0] AH01071: Got error ‘PHP message: PHP Fatal error: Cannot redeclare readMyPoints() (previously declared in /home/…/public_html/home/modules/House Points/hook_housepoint.php:40) in /home/…/public_html/home/modules/House Points/hook_housepoint.php on line 40’, referer:

Hi Tieku,

Ah yes, this is a bug, and I’ve jsut been able to re-produce it in v1.5.00. I’ve created a fix, and released it as v1.5.01, and you can see the changes in the commit linked below:



PS, it looks like v1.5.00 (which contains further refactoring) had been released, but not uploaded to our Extend page, which explains why you are using an older version.

Hi Ross

I am meeting a different problem but related to the 1.5.01 update. 1.4.01 is able to show all points categories when awarding points. 1.5.01 is only able to show house categories only. student categories are missing.

I have tried removing and purging the module table and start a fresh the same problem persists. reverting to the older module, version 1.4.01, fixes the problem. Attached are a few screenshots of the problem.


Hi ngn, thanks for the heads up, looks like it was a bug from some recent refactoring of the module. I’ve fixed it, you can find v1.5.02 on the Extend page. Thanks!