Editing Behaviour Records

Hi all i am having some problems with Behaviour Records not sure if its meant to be this way ? inputting the information and saves ok, but the problem starts when i try to go back in to edit a Behaviour Record like to add more information ECT it allows me to type in the extra information but when i press save i am getting (((( Your request failed because your inputs were invalid. ))))
not sure why its doing this is this normal after saving a Behaviour Record to not be able to go back in to edit or add more information to the Record ?

Thanks Orlando

I forgot to say i had this as a add-on to a other post problem i was having with dashboard but i thought to start a new post as i manage to short out the dashboard problem but Behaviour Records issue is still ongoing

Works alright for me. Try rebooting the server if possible, do not do this if it will delete anything or you will have trouble restarting it. You could also upload a photo of your input and then the error, before you try this.

Hi i restarted the server still no change please find my error log attached i am sure theres hints in the error massage (( Your request failed because your inputs were invalid. )) why is it saying inputs were invalid

Sorry forgot to add a picture of the front end error

Orlando, is this happening on v13 or v14?

I’ve not been able to recreate the issue (e.g. it is working fine when I test it), but I can see from the code that this can occur in one of two places in the process script. Please can you replace your current behaviour_manage_editProcess.php file with the attached (you’ll have to unzip it first), and then try again, and let me know if you see a white screen with “here” or “there” outputted to it. This will help us narrow down the possible options.



Hi i am running v13 at the moment tried v14 on a mock sub account i made with v13 database but was having problems with the update but its because i was using utf8_general_ci and now on utf8mb4_unicode_ci so the v14 update did not like that but i am still working on it.
where do i need to put behaviour_manage_editProcess.php file.

Orlando, utf8mb4_unicode_ci is new to me. I guess it offers 4 byte character encoding, which supports emoji. I’ll add this to our todo list to looking into. You can see it here.

Sorry I did not make this explicit: place the file into /modules/Behaviour

Good luck!


Hi i put the file in /modules/Behaviour but not noticed any thing deferent theres no white screen with “here” or “there” outputted to it, just getting the same error as before (( Your request failed because your inputs were invalid. )) if you would like a login to the site to have a closer look please let me know how i can send you the info off the form wall thanks

Update i just updated to V14 with no problems working perfect but i was hoping that the Behaviour Records error
->-> (( Your request failed because your inputs were invalid. )) would have gone away but its still there i am now think if its a MSQL problem ? its like a ghost code problem lol

Orlando, a log in to the site would be useful, but ideally I also need to be able to edit your files to try and work out what the problem is. Any chance of SSH (preferred) or FTP access?


Hi Ross i have email you the login information for my Cpanel to support@gibbonedu.org let me know if you received it thanks for your help

Orlando, OK, I am in your system: I notice you uploaded the test file I sent as a .zip: next time try and extract it and then upload the .php file inside it.

I’m looking now, and will let you know what I discover.

Orlando, I have disocvered that each of your behaviour records have a date in the database, but this date is not showing up when viewing or editing records:

I am now trying to work out why this is happening, when the data is there.


OK, problem solved! For some reason your Gibbon database table gibbonBehaviour had the field name “date” spelled as “Date” with a capital “D”…to the PHP web server engine these are then two different things, and so certain things stopped working.

I cannot imagine how it came to be Date, as it is certainly not like this in the installer. Has someone been playing with your database at all?

At any rate, I’ve changed it back, and it should now be working.

I’ve cleaned up after myself, deleting the account I set up in the database to be able to get into your Gibbon install.



Hi Ross thank you so much for your help with this its all working great, no one has done any work on the database but me and the only thing i did was move the database from a US hosting Provider to our own server not sure if migration could have done this–> date to Date in the database. Hats off to you for finding a needle in a haystack i spent two weeks trying to do what you did in a few hours and then cleaned up after wow.

A BIG thank you once more to shorting out this problem could not have done it without your help

Orlando, appreciate your gratitude and thanks : ) The haystack seems much smaller when you built the system!

It would be highly unlikely for this to happen in the migration, but that does seem the most likely candidate. You never know with computers…

Good luck with your ongoing rollout of Gibbon, let us know as you need help.

Thank you Ross