creating invoice problem

i have a challenge where last term(1st term year 2021) i created invoices well and billed them. however 2nd (2nd term year 2021
)term i create the invoice but they can not be created and it echoes “Your request failed because your inputs were invalid.”
please help. attached is the screen shot

attached is the zipped database. kindly help me resolve this

Edit: attachment removed by admin.

Hi viny254, I’ve removed the database to protect your privacy, as these are public forums.

Hello, Viny! While your database is useful, it would be more useful to know what inputs you have selected further down the page, below the cutoff of the screenshot. It would also be good to know what version of Gibbon you are using. If you can give us this information, then we can help you further.

Thank you!

thanks. attached is the lower screen shot.
am using Gibbon Version v21.0.01 and php version PHP Version 7.4.24. the invoice adding was working but just stopped. kindly assist.

Hi viny254, It looks like something is going wrong with the fees, as you’ve selected an entry in the dropdown, but no block has appeared. With no fees the invoice won’t save properly. Can you check your browser’s console to see if you are getting any JavaScript errors? thanks!

no errors. i have even tried with diffent computers and different browsers but i get the same error

when i do a separate installation it works well. so i believe the problem is not the browser. this is strange.

could it be a permission issue?

I notice that there is a ’ in the fee name, and sometimes these can cause issues in javascript, can you test removing the single quote from the fee name?

i tried and it did not work. i even tried those with no comas. just a single word and wont work.i even cleared cache but the issue remain which file and line codes handle that? perhaps you can give me a fresh code to pick the fee. i can also give you the cpanel or the login you try from your side. tell me where to send them.

which is the javascript code od file that fetch the fees?

i even istalled version 22.0 and linked the same database and its giving the same error. am left with only one option which is to intall the latest version and then i copy all users, library, classes roll groups. for finance i can do it again. guide me on that

kindly someone help me resolve this issue

Hi viny254, we’d certainly like to help so you don’t have to get to that point! Have any other server settings or software versions changed on your system since you used this feature last? It can be difficult to resolve an issue that we’re not able to reproduce on our end. If you are able to send a set of login credentials to we can try and take a look at your system to see if we can help identify the cause.

i got it solved eventually. i realized that javascript was not working at all in the software. so i downloaded the same version and replaced all the files but letting config.php and the database remain intact.So whatever the problem was it was solved. i just shared it so that incase someone else faces a similar problem can try that

Great to hear you found a solution! Thanks for sharing it here :smiley: