# CentOS Nginx installation problem:Your request failed because you do not have access to this action.

**URL:** <https://ask.gibbonedu.org/t/centos-nginx-installation-problem-your-request-failed-because-you-do-not-have-access-to-this-action/3316>\
**Category:** Installation\
**Created:** [December 16, 2021, 4:39pm UTC](https://ask.gibbonedu.org/t/centos-nginx-installation-problem-your-request-failed-because-you-do-not-have-access-to-this-action/3316 "2021-12-16T16:39:14Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nonicker](https://ask.gibbonedu.org/letter_avatar_proxy/v4/letter/n/ecc23a/32.png) [@Nonicker](https://ask.gibbonedu.org/u/Nonicker)\
**Post date:** [December 16, 2021, 4:39pm UTC](https://ask.gibbonedu.org/t/centos-nginx-installation-problem-your-request-failed-because-you-do-not-have-access-to-this-action/3316/1 "2021-12-16T16:39:14Z")

</div>

Hi,

i tried to install Gibbon v22.0.01 on Centos 8, Nginx 1.14.1, MariDB 10.3, PHP 7.3.32. Web installer opens, STEP -1  
The directory containing the Gibbon files is writable, so the installation may proceed, System requirements all green (checked and ok), but upon Submit i get the following error:  
**Your request failed because you do not have access to this action.**

This server is running few sites (wordpress)located in subfolders /usr/share/nginx/site1; /usr/share/nginx/site2; with proper config files in /etc/nginx/conf.d. Gibbon is located /usr/share/nginx/gibbon with proper permission (chmod -R 755). Anyone here had similar problem with this?  
Thank you.

---

<div class="post-metadata">

**Author:** ![Nonicker](https://ask.gibbonedu.org/letter_avatar_proxy/v4/letter/n/ecc23a/32.png) [@Nonicker](https://ask.gibbonedu.org/u/Nonicker)\
**Post date:** [December 17, 2021, 7:39am UTC](https://ask.gibbonedu.org/t/centos-nginx-installation-problem-your-request-failed-because-you-do-not-have-access-to-this-action/3316/2 "2021-12-17T07:39:02Z")

</div>

Update:  
i’ve managed to install Gibbon by commenting //Config session lines in /installer/install.php  
But, after installation it’s impossible to login.

---

<div class="post-metadata">

**Author:** ![Nonicker](https://ask.gibbonedu.org/letter_avatar_proxy/v4/letter/n/ecc23a/32.png) [@Nonicker](https://ask.gibbonedu.org/u/Nonicker)\
**Post date:** [December 22, 2021, 9:11am UTC](https://ask.gibbonedu.org/t/centos-nginx-installation-problem-your-request-failed-because-you-do-not-have-access-to-this-action/3316/3 "2021-12-22T09:11:01Z")

</div>

This is solved. It was a problem with /var/lib/php/session owner and permissions. Gibbon by default uses that path to store session data.  
CentOS/Nginx by default uses root:apache for /var/lib/php/session. By adding nginx to apache group (or just simple chown -R nginx:nginx /var/lib/php/session) this problem is solved.

---

<div class="post-metadata">

**Author:** ![ross](https://ask.gibbonedu.org/user_avatar/ask.gibbonedu.org/ross/32/8_2.png) [@ross](https://ask.gibbonedu.org/u/ross)\
**Post date:** [December 23, 2021, 2:02am UTC](https://ask.gibbonedu.org/t/centos-nginx-installation-problem-your-request-failed-because-you-do-not-have-access-to-this-action/3316/4 "2021-12-23T02:02:08Z")

</div>

Thanks for sharing your solution : ) This is really useful to have available for other users.

---

<div class="post-metadata">

**Author:** ![rprice1978](https://ask.gibbonedu.org/letter_avatar_proxy/v4/letter/r/dec6dc/32.png) [@rprice1978](https://ask.gibbonedu.org/u/rprice1978)\
**Post date:** [January 4, 2022, 4:54pm UTC](https://ask.gibbonedu.org/t/centos-nginx-installation-problem-your-request-failed-because-you-do-not-have-access-to-this-action/3316/5 "2022-01-04T16:54:09Z")

</div>

is this whats happening when cloning a site then upgrading?
