Cannot import user data. Failed at live run.

So I tried to import user data using the format that I got when I choose to export data. Step 3 went without trouble. However, the process failed at step 4. It only says “Your request failed because your inputs were invalid.” without any other information why the inputs were invalid. I already searched for a solution but couldn’t find any.

Hi fakhri, are you able to try the import with just the first row? If this still does not work, then email us that row at and we can test it out for you. If it does work, then maybe the difference between that and other rows can indicate the problem.

The row number causing the error is given in the error output: sometimes I find it is off the bottom of my table, because the spreadsheet has some empty rows below the data. Deleting all rows below the data can help with this.



Hi fakhri,

One of the steps the dry run won’t be able to detect is the uniqueness of values within the import itself. It can compare it to existing records, but in the live run as records are added it may generate an error if there is something within the spreadsheet that is not unique, such as usernames or student IDs. As Ross has recommended, trying with just one row as test may help.

Hi @admin Ross and @ross! Thanks for responding. I managed to find the cause of my problem. The solution that Ross provided didn’t solve the problem. But it got me thinking that the problem might be caused by something I did. After paying more attention to all the options, I found out that I need to choose the right mode when importing which is “Insert” only. Before, I didn’t change anything and left the mode at default which is “Update and Insert”. I feel really embarrassed now. Anyway, I’ve been tinkering for a few hours and start to get the hang of using Gibbon. Really like it.
Once again. Thanks for your response.

Hi Fakhri. Great to hear that you solved it! Don’t feel embarrassed, Gibbon is complex and has a long learning curve. Welcome to the community : ) Ross