Hello team there’s kinder bug we are experiencing under batch report generate[reports module]. Runs succesfully[on url] but no report generated.

Running the same reports under [reports_generate_single] all reports are generated successful only that you have to download the pdf’s one by one.

Checking system status: everything looks okay[cheecked].

[Gibbon version 23.0.01[updated]]

Batch reports work using background processing, and should notify you via email when they are done. If this is not happening, perhaps your background processing isn’t working as expected, which can happen if your web server does not have permission to execute php scripts on the cli. Can you check your logs in System Admin > View Logs, and filter to Background Process - GenerateReportProcesss and see if there are any errors or indications that the process is still “running” which may indicate it didn’t start. To test this, you could disable background processing in System Settings, and then run the batch again, but note that the page may hang for 15+ minutes depending on the volume of reports being generated (and the page would need left open until it completes).

Backgound Process is turned on, the logs view looks like:

showing ready as per “the process was successful” but no PDFs generated.

When turned off:
runs as you stated

I tried executing php files on cli and seems to run okay but the above issue is still on.

Hmm, status Ready sounds like the process is being added but isn’t running as intended, as the status should immediately change to Running and then Complete when done.

Can you check your regular PHP error logs to see if there’s anything in there? Sometimes the PHP cli doesn’t write to the same error log, you may have to manually edit the cli/system_backgroundProcessing.php script and add

ini_set(‘log_errors’, 1);
ini_set(‘error_reporting’, E_ALL & ~E_DEPRECATED);

to it next to the set_time_limit().

I wonder, is background processing working in other areas, such as sending emails via messenger? If it’s not, then that may certainly indicate that it’s related to server configuration.

I added the above code but still no php errors in my normal php error log file. From your last suggestion mails are not sending as they used to, so this could be a server config issue.
Permissions looks to be set okay[file ownership & write permission]

I’m still trying to dig into this, meanwhile setting background process of has helped us manage to run reports normally but a temporary solution at the moment.

Meanwhile thank you @ross for always assisting.