spanish translation

Hi everybody i newbie using gibbon, i recently installed , but i cant change english to spanish language of system, i use mozilla firefox browser and have added spanish/mexico language , but still in english.

Comments

  • i noticed a misconfiguration of gettext, only had to set the locale to es_ES instead of es_MX and i solved the issue, thanks.
    admin
  • edgarobles, welcome to the Gibbon community, and thanks for solving your issue and sharing the solution : ) The change you made to the locale, where did you make those? I just want to make sure I understand your solution so I can make sure it won't cause you issues down the line.
  • Hi. First of all thank you for this help site. I have problems activating the Spanish language throughout the site. I have configured all the administrative parameters to activate the Spanish of Spain, but it does not work for me. Is there a manual configuration that can be configured somewhere in the code? Thank you
  • Jorge, thanks for getting in touch, and welcome to the Gibbon community. I am guessing the issue is to do with not having the correct locales installed in your operating system. Please can you let us know what OS type/flavour/version you are using (e.g. Ubuntu Linux 16.04), and we will try and help you. Ross.
  • Hi admin, same issue, I am using a desktop version of Ubuntu Linux 16.04 LTS, tried to install the locales and no changes. Thank you for all of your support
  • adminuvam, that is very odd. Most of my experience is with Ubuntu Server, but the stack should work the same as the desktop version. Do you have gettext installed? Can you check your error log to see if there are any error messages being generated? Thanks, Ross.
  • I had this problem and sorted it out based on the comments above. To summarize:

    I found a helpful forum post that describes how to install locales.

    1. Check to see which locales are installed: locale -a
    2. Install the locale you need: sudo locale-gem fr_FR or sudo locale-gen fr_FR.UTF-8
    3. Run: sudo update-locale

    Finally, install getttext: sudo apt-get install gettext

    Those steps worked for me.
    admin
  • Hi everybody i recently installed gibbon, but i can't change english to spanish language of system, i use mozilla firefox browser and have added spanish language , but still in english, my SO is Debian 9 and gibbon 15.0

    1. Check to see which locales are installed: locale -a
    en_US.utf8
    es_ES
    es_ES.iso88591
    es_ES.utf8
    es_MX
    es_MX.iso88591
    es_MX.utf8
    POSIX

    2. i already ran the command: sudo update-locale
    3. i already installed gettext: sudo apt-get install gettext
    4. Check locale config: locale -v

    LANG=es_ES.UTF-8
    LANGUAGE=es_ES.UTF-8
    LC_CTYPE="es_ES.UTF-8"
    LC_NUMERIC="es_ES.UTF-8"
    LC_TIME="es_ES.UTF-8"
    LC_COLLATE="es_ES.UTF-8"
    LC_MONETARY="es_ES.UTF-8"
    LC_MESSAGES="es_ES.UTF-8"
    LC_PAPER="es_ES.UTF-8"
    LC_NAME="es_ES.UTF-8"
    LC_ADDRESS="es_ES.UTF-8"
    LC_TELEPHONE="es_ES.UTF-8"
    LC_MEASUREMENT="es_ES.UTF-8"
    LC_IDENTIFICATION="es_ES.UTF-8"
    LC_ALL=es_ES.UTF-8

    5. ... and no changes. What else can be done?
    Thank you for all of your support
  • Hi Jorge, thanks for your patience whilst we found time to look at your post. Can you clarify the following:
    1. The commands run and output shown above are on the server side (you might be running Linux/Mac on desktop, and so I want to be sure)
    2. In which part of Gibbon have you changed your language? Installer, System Settings, personal Preferences, or at login?
    Once we have this information we will be in a better position to respond. Thanks!
  • Hi,
    As I said in the previous post, my operating system is Linux Debian 9, mounted on a virtual machine in Microsoft azure, running on apache virtual host pointing to my test domain, as for the configuration I did it everywhere you mention, thanks for your help
  • Hello, thanks for taking the time to clarify. The previous post was a little ambiguous, so I just wanted to be 100% clear. Have you checked your PHP error logs to see if there is any mention of anything relevant in there? Thanks! Ross.
Sign In or Register to comment.