Assistance with installation of Gibbon

I am attempting to install Gibbon on Windows Vista. Firstly, I am a novice at all of this, so I have very little experience. I have Bitnami WAMP downloaded and installed on my computer. I can access myphpadmin portal through that and go to my localhost through 127.0.0.1:8080. The next/first step on the guide is to "Copy all files to your server, choosing either the root director or a sub-folder within it."

I don't understand that part at all. Where am I supposed to by copying my files to? I have my WAMP folder in my C: drive, and my gibbon folder is located in C:/wampstack/apache2//htdocs/Gibbon. Can you please assist me with this? Thank you.

Comments

  • Kyle,

    Thanks for your post, and welcome to the Gibbon community. htdocs is know as your web server's "document root", and anything placed in there will appear when you browse to the URL of your server. If you are just using WAMP, this would most likely be https://localhost. So, if you want Gibbon at that address, then put the contents of the uncompressed ZIP folder into htdocs. However, if you want Gibbon installed at, say, https://localhost/gibbon, then make a folder called gibbon in htdocs, and place the files in there.

    Hope this helps, let us know if you have any further questions.

    Ross
  • Ross,
    Thank you, that was very helpful. I have done so, and ran into a second obstacle. I go to the URL of my server and the Gibbon installer comes up, but nothing happens. This is the extent to what the page loads.A background of snow capped mountains, and a white header box with the Gibbon logo in the top left corner. Have I done something wrong? Please assist. Thank you.

    image
  • Kyle,

    It sounds like some kind of PHP error is stopping the page from loading, but that your server config is stopping the error from displaying on screen. I guess you do not have gettext installed in PHP...but that's just a guess.

    Next step is to either check your PHP error log to see what error it is, or edit php.ini to turn on errors on screen. Once you know what the error is, post the error details here, and we can help suggest solutions.

    Thanks,

    Ross
  • Ross,
    Thanks again for the guidance. I just want to preface this with how inexperienced I am with all things OpenSource, PHP, etc. Is it possible to be pointed in the right direction of a step by step guide for doing even what you just suggested above? I found the php.ini file, but was not sure which part of it to edit to change to display errors on screen. As always, any help with this is appreciated. Thank you.
  • Kyle,

    We've all be there, don't worry! A huge amount of my own learning came via such forums, at the hands of very caring and experienced users, who took the time to guide me. That's why open source focuses so much on community!

    In php.ini find the setting display_errors and set it from off to on. Save the file and restart your web server (Apache most likely), which will reload PHP's config file. Then reload the Gibbon page, and see if that helps.

    Good luck, and keep the questions coming : )

    Ross
  • Ross,
    Well, I can definitely say I am learning a lot, if I'm understanding it all, that's another question. So after making those changes it did do something, which I hope means progress. Here is the error that showed up on screen.

    Fatal error: Call to undefined function _() in C:\wampstack\apache2\htdocs\Gibbon\installer\install.phpon line 86

    I'll await a response. Thank  you.
  • Kyle,

    Yup, that's how it goes. Often we need to do something a number of times, or encounter more related concepts, to really understand how it connects to other things and broaden our map of understanding. That is, I guess, why there is no shortcut to experience : )

    _() is a short cut for the gettext command, which performs translation. Your PHP install currently does not have gettext installed. The following Google search might help you narrow in on an answer:

    https://www.google.com.hk/search?q=wamp+php+instal+gettext&ie=utf-8&oe=utf-8&gws_rd=cr&ei=YxfWVrLrO4XK0gTR6LCABg

    Good luck,

    Ross

  • Ross,
    I thought that I followed the directions to install gettext, but now I am back to where nothing shows up on the Gibbon installation page. I looked at my Apache Error Log from Bitnami WAMP Stack Manager Tool and saw all of these:

    [Wed Mar 02 19:15:12.189600 2016] [mpm_winnt:notice] [pid 7640:tid 232] AH00354: Child: Starting 64 worker threads.
    [Wed Mar 02 19:20:03.941400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Notice:  Undefined variable: databaseServer in C:\\wampstack\\apache2\\htdocs\\Gibbon\\index.php on line 37
    [Wed Mar 02 19:20:03.941400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Notice:  Undefined variable: databaseName in C:\\wampstack\\apache2\\htdocs\\Gibbon\\index.php on line 37
    [Wed Mar 02 19:20:03.941400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Notice:  Undefined variable: databaseUsername in C:\\wampstack\\apache2\\htdocs\\Gibbon\\index.php on line 37
    [Wed Mar 02 19:20:03.976400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Notice:  Undefined variable: databasePassword in C:\\wampstack\\apache2\\htdocs\\Gibbon\\index.php on line 37
    [Wed Mar 02 19:20:04.121400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Notice:  Undefined variable: guid in C:\\wampstack\\apache2\\htdocs\\Gibbon\\index.php on line 48
    [Wed Mar 02 19:20:04.121400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Notice:  Undefined variable: guid in C:\\wampstack\\apache2\\htdocs\\Gibbon\\index.php on line 52
    [Wed Mar 02 19:20:04.122400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Notice:  Undefined variable: caching in C:\\wampstack\\apache2\\htdocs\\Gibbon\\index.php on line 55
    [Wed Mar 02 19:20:04.122400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Notice:  Undefined variable: guid in C:\\wampstack\\apache2\\htdocs\\Gibbon\\index.php on line 65
    [Wed Mar 02 19:20:04.122400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Notice:  Undefined variable: connection2 in C:\\wampstack\\apache2\\htdocs\\Gibbon\\index.php on line 66
    [Wed Mar 02 19:20:04.122400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Fatal error:  Call to a member function prepare() on null in C:\\wampstack\\apache2\\htdocs\\Gibbon\\functions.php on line 3500
    [Wed Mar 02 19:20:04.400400 2016] [:error] [pid 7640:tid 864] [client ::1:57935] PHP Fatal error:  Call to undefined function _() in C:\\wampstack\\apache2\\htdocs\\Gibbon\\installer\\install.php on line 86


    I'm not sure if this will be helpful or even relevant.
  • Kyle,

    That is a lot of errors, and not what we are used to seeing. Could you try and remove WAMP, and instead try XAMPP? I have heard people having better experiences with it in the past. Plus, we have an install guide: https://gibbonedu.org/support/administrators/installing-gibbon/install-xampp/

    Thanks,

    Ross
  • Hi,

    I am having some trouble with the installation. I am using CentOS7, and mariadb. So far I confirmed HTTPD, PHP, and mysql are up. I go to the localhost/gibbon and it takes me to the installation page, but then when trying to access the database, i get an error that " A database connection could not be established. Please try again."
  • Aremis,

    As far as I know Gibbon has not been tested with MariaDB: it was only designed for use with mySQL, and that is how most people use it. Are you coder? Do you have the ability to look at how PHP might use the PDO class to connect to Maria DB instead of mySQL?

    Thanks,

    Ross
  • thank you for your reply! I actually used root instead of the user i created and it worked. So far, it works fine. I loaded the test data. For the production installation, i'll use mysql
    admin
  • Great to hear that it works with MariaDB! Thanks for letting me know.
  • Hi Ross, with regard to Kyle's problem above....I had the same issue and just had to edit the php.ini file and add extension=php_gettext.dll
    admin
  • Woohoo I'm human!!! :smiley:

    I'm having several problem with my install (v12.0) and I wasn't sure whether to post the first problem here or in translation...Gibbon Installed fine...but I want to use English and Spanish languages. I installed it with default language set to English. Then after logging in, I went to user preferences and changed my language to Spanish. Logged out; Logged back in; but the system is still in English. :(

    Another problem is with themes. I've copied the Seafarer and Time Forest themes into the gibbon/themes folder, but they don't appear as options in the preferences screen.

    And finally, i'm using bitnami wampstack, which is really slow, but the screens are displayed completely. i'm guessing it's a timeout issue...anyone run into this?

    cheers
  • scratch number 3, I found how to install themes.
  • Mykl, good job for solving and sharing the solution to the original issue. Please can you post any other outstanding issues to separate threads, so we can answer there? Welcome to Gibbon!
  • Hi, just want to pitch in that we have been running Gibbon on MariaDB from the very beginning. MariaDB is "just" a fork of MySQL made by the original founder of MySQL itself.
    It's supposed to be a drop-in replacement for MySQL, and so far in my experience it works perfectly anywhere you would use MySQL. And usually faster.
  • Urko, thanks for adding this, it is a great bit of information to have available, and I appreciate your willingness to share experiences like this. Ross.
  • Hi Ross,

    I am installing Gibbon on a new Centos 7 VM.
    I have installed everything but keep getting "The directory containing the Gibbon files is not currently writable, so the installer cannot proceed." at installation step 1.

    A nudge in the right direction will help me alot.

    I did the same set-up about a year ago, but somehow seem to have missed something, somewhere.

    Thx
    Jean
  • Jean,

    I suggest you look at using ls -l to list your web root directory (most likely /var/www or similar) to check the file permissions of your Gibbon directory. You could then use chmod to adjust those permissions.

    Hopefully this is enough of a nudge : )

    Ross
  • well... what secure permission we need for each gibbon folder, by now i still use chmod 777 bcus i still try gibbon on my localhost, btw is gibbon have API? and where i can get the full documentations of it, thanks for advance :)
  • Hi @creatorbe

    Setting permissions to 0755 is a good starting point for anything that's not your localhost. There isn't an API in the RESTful sense, but the full documentation can be found on the Gibbon website: https://gibbonedu.org/support/ including post-install & server config, links to the github repo, and development roadmap.
  • Hi
    I am trying to install gibbon on windows 7, I am using Xampp control panel version 3.2.2. I have successfully launched the installation on my browser but i cannot get past the second step of installation, i get this error "SQLSTATE[HY000] [2002] No connection could be made because the target machine actively refused it." please help anyone
  • Ike, that is an interesting error, and not one I have seen before. I presume that this is an SQL error, to do with configuration in Xampp. Have you tried to establish a MySQL connection from a client (such as https://dbeaver.jkiss.org) to see if it will accept a connection at all? This would be a good way to see if the error is with Gibbon and MySQL, or purely MySQL. Good luck!
Sign In or Register to comment.