fresh installation error in the beginning

bismillah
Hi,
i am a newbie in gibbon. i have download v 24 and upload to my local mac server. but when i access http://localhost browser show error
Something has gone wrong: the Gibbons have escaped!

An error has occurred. This could mean a number of different things, but generally indicates
at first i thought its my server, after that i upload to my dev server on remote server and i try to access the link but the error still there. so i thought its the code. so i download v23.0.0 and reupload to my remote server. but the result is the same.

Oh no!
Something has gone wrong: the Gibbons have escaped!

An error has occurred. This could mean a number of different things, but generally indicates that you have a misspelt address, or are trying to access a page that you are not permitted to access. If you cannot solve this problem by retyping the address, or through other means, please contact your system administrator.


please advice me. what must i do.
tyvm

Comments

  • in php error log i found this

    PHP Fatal error: Uncaught RuntimeException: Unable to create the cache directory (/var/www/html/uploads/cache/36). in /var/www/html/vendor/twig/twig/src/Cache/FilesystemCache.php:53\nStack trace:\n#0 /var/www/html/vendor/twig/twig/src/Environment.php(349): Twig\\Cache\\FilesystemCache->write()\n#1 /var/www/html/vendor/twig/twig/src/Environment.php(309): Twig\\Environment->loadTemplate()\n#2 /var/www/html/vendor/twig/twig/src/Environment.php(277): Twig\\Environment->load()\n#3 /var/www/html/src/View/View.php(120): Twig\\Environment->render()\n#4 /var/www/html/src/View/Page.php(486): Gibbon\\View\\View->render()\n#5 /var/www/html/installer/install.php(214): Gibbon\\View\\Page->render()\n#6 {main}\n thrown in /var/www/html/vendor/twig/twig/src/Cache/FilesystemCache.php on line 53
  • Hello, well done on checking the PHP log! Because the web server cannot create a sub-folder within /uploads/cache, it is unable to properly generate the pages it is being requested to.

    This will be a file permission error, most likely on /uploads/cache. What kind of server are you on, and do you have the ability to adjust file permissions?

    Cheers,

    Ross
  • ok. done, my mistake. i change owner of homebase dir to another user. tyvm for your advice.
    admin
  • I've been having errors also. I was able to fix one but now I'm not sure what can be the reason. This is what my log shows,

    [30-Jun-2022 06:47:06 UTC] Installer: Step 1: assigning random guid: 'gn0kfr97-ieor-noby-6xb-uvqeo54nx8o'
    [30-Jun-2022 06:47:58 UTC] Installer: Step 1: Using guid from $_COOKIE: 'pox4frbzx-3zed-7sg9-vqfm-ti2ttqdz63g'
    [30-Jun-2022 06:47:58 UTC] Forbidden:
    #0 /home/zbrzwqzl/public_html/sms/src/Install/Http/InstallController.php(323): Gibbon\Install\Http\NonceService->verify('4169bc37d9', 'install:locale')
    #1 /home/zbrzwqzl/public_html/sms/installer/install.php(101): Gibbon\Install\Http\InstallController->handleStepOneSubmit(Object(Gibbon\Session\Session), Array)
    #2 {main}
  • Hi jgalarza, be sure to check your file permissions, a Forbidden error sounds like your server might not have access to the files it needs.
    jgalarza
  • I tried on another computer and it is working. I guess is a problem with the computer that has been blocked. Thank you for your advice.
    sandra
Sign In or Register to comment.