Lesson Planner stops auto filling lesson dates

Normally when I click Add on the lesson planner, (I do it from the Yearly Overview usually), the system will and should autofill the lesson date for me. This is an awesome feature that saves me a ton of time. After some time though, this feature no longer works, and I'm forced to return to the yearly overview page and click the + in the lesson slot I'm planning for.

It seems like this is a bug of some sorts.

Comments

  • Hi Qualitymix, this does indeed sound like it might be a bug. A good first step in helping us track this down is to check your PHP logs and let us know if there are any relevant entries. If there are, please share them here. If there are no entries, we can try some other approaches to troubleshooting. Thanks! Ross
  • There do not appear to be any entries regarding the lesson planner module.
  • I had a teacher report this same issue. It seemed to be related to a holiday occupying the usual time slot. But I have not tested it further. Is there any difference in the time slot where it stops working or does it seem related to the number of lessons created (i.e. time spent in the planner in the same browser session)?
    Qualitymix
  • Hi Qualitymix, FV might be onto something here, given your previous posts about adjusting term times, and special days not getting cleaned up. We've fixed this issue in v23 (due for release on January 20th 2022), but you might want to check your database table gibbonSchoolYearSpecialDay for rouge entries. Cheers, Ross
    Qualitymix
  • I'll look into these issues. It seems that, after a certain date ( I have not nailed down yet), the planner ceases to autofill for the next available lesson date. I'll track down if there is anything going on for holidays or otherwise.
  • It seems that I cannot Untie a Day from the schedule. I think that I tied all the days of our semesters to dates for school, and then added holidays that overwrote the days tied. Now the system is competing with itself for the ability to add lesson plans on days that are tied to dates but also marked for school closing. How can I fix this?
  • I'm sorry to hear that this is proving so intractable. One option might be to remove everything in gibbonSchoolYearSpecialDay for the current year, check if that solves the issue, and then add in the real special days again.
Sign In or Register to comment.