Gibbon language doesn't display unless system language changed

Hello team Gibbon.
A new day with a new question.

Just to confirm.
Is it true that if I want to change the language in Gibbon (to other than English), then I must change my system language too, in order to display my desired language in Gibbon?

Because I want Gibbon to be in Dutch and my system language is in English. I've installed the Dutch language in Gibbon, the language doesn't change unless I change my system language to Dutch.

Comments

  • Hi abdulfattah,

    This may depend on your server and how it is setup. Are you running on Linux or Windows? We have seen issues in the past with Windows servers and language setup. For Linux, you should be able to just install the additional languages, check the docs here for instructions: https://docs.gibbonedu.org/administrators/misc/internationalisation/
  • Yeah I'm using windows.
  • Hi abdulfattah,

    We aren't always able to provide the best support for Windows, as the core team primarily uses Linux in production and MAMP locally on Mac, but we will try our best. In this case, you may need to also do some searches online to see how to enable locales on a Windows server. Also, be sure to check your System Admin > System Check page to see if the gettext library is enabled.
Sign In or Register to comment.