Student cannot view report

Good day. I have generated a report and the pdf is confirmed in the uploads subfolder with the correct information. But the students that are in the report cannot view the report. When the student account goes to Assess > Reports, the message displayed is "There are no records to display". Clicking the "View Reports" link will also display the same message. What steps am I missing?

The report has these settings:
1. Reporting scope type = course
2. Reporting cycle end date = Apr 10, 2021
3. Access end date = Apr 10, 2021
4. Generate report option chosen is "Final" and not Draft

I did not change Admin > User Admin > Manage Permissions:
1. View Reports_mine = has check mark for Student

Comments

  • Hi Richard,

    There are a number of areas that control access to reports, as checks and balances to help ensure they're never visible when you don't want them to be. Check out the list in the docs here and see if this helps: https://docs.gibbonedu.org/administrators/reports/publishing/#parent-and-student-access

    A couple thing to check might be the User Permissions access to the View Reports_mine action. Also, that the archive you're using is open to students, in Reports > Manage Archives.
  • Hi Sandra, thanks for pointing me to Manage Archive. I now changed 'Viewable to Students' to Yes. But the report still is not visible to the student account. I tried to re-generate the report (set to Final) and restart the server but the issue remains.

    Is the location of the report a factor? Because I changed the report and cache folders to be under "/sisuploads". The generated pdf are placed in the new subfolder under "/sisuploads/reports/.
  • If you test it yourself and you can download it, then the location of the PDF shouldn't be an issue. Can you check to see that you can see the report for a student if you go into Archive > View by Student.
  • Thanks Sandra for the reply. When I login as administrator and chose Archive > "View By Student" I can view and download a student's pdf. But when I login as any student and chose Assess > Reports, it will display "There are no records to display"
  • Hi Richard, You mentioned the Access End Date. In Manage Reports, have you also set the Go Live date for the report? There's a date and time at the bottom when you're editing the report, and this determines when the report becomes available to parents and students.
  • Thanks Sandra setting the Go Live date solved the issue!
  • Great to hear! I know there are lots of checks and balances, but the possibility of accidentally showing reports when you don't intend to is at least much lower because of it.
Sign In or Register to comment.