i can´t install Gibbon core

hi, i tried to install gibbon core at my server but only appears "Installation - Step 1The directory containing the Gibbon files is writable, so the installation may proceed." and I don´t have any option to continue. that´s the screen.



I thank you if you can help me to solve the problem

PDT. I use php 7.2.24

Comments

  • Hi redcat8908,

    Thanks for choosing Gibbon, and welcome to our forums.

    What you are seeing is the correct text, but all of the context is missing. You should see it in this form:



    I suspect you are running into a PHP error, which is then not allowing the rest of the page to run. Are you able to check the PHP error logs on your server, to see what you find? We can help you interpret it if needed.

    Cheers,

    Ross
  • I saw something similar about two years ago when I created an Ubuntu Linux test server for evaluation before we decided to use Gibbon. I don't remember the details, but there were some settings in the default configuration of Apache web server that were necessary for the .php files to run instead of displayed as html or text files. It seems like there was an additional package required beyond what was in the install instructions for Gibbon. The file permissions also would come into play, but were not the problem I had. The user and group for which the Apache program runs also affects it. I wish I could remember more, but it was too long ago.
    -- Glenn
  • Hi Glenn, funnily enough, just last night I upgraded someone else's WordPress server from Ubuntu 16.04 LTS. This meant jumping from PHP5 to 7. After the upgrade, Apace started behaving like this, returning the raw PHP. This can be super dangerous, as wp-config.php (or config.php in Gibbon's case) is returned with password visible. In this case it is non-issue, as redcat's install does not yet have a config.php.

    At any rate, the solution, and I think this is what you are getting at, is to run Apache's a2enmod command on the correct PHP version, as discussed below:

    https://stackoverflow.com/questions/35988990/how-to-enable-php7-module-in-apache

    Hope this helps redcat get up and running. Thanks for contributing Glenn!

    Ross
    sandra
  • Ross, when I saw the a2enmod name I recognize it, and think that is what I had forgotten. Thanks for all you do in keeping all of us straight!

    -- Glenn
    admin
Sign In or Register to comment.