HTTP Error 500 - Initial Install -Core ver. 18.0.01

Hello,

I'm having an issue with being able to load the installer.

Info you will want to know:

OS: CentOS 7
PHP: PHP 5.4.16
Mysql: Server version: 5.6.46 MySQL Community Server (GPL)

I have disabled the firewall, selinux.
I have verified that php, httpd, and mysql are running.
I have changed the webroot to both 755 and 777 (to see if that makes a difference)
Installed all required php modules outlined in the installation guide.

This is the error that I receive when I look at the apache logs.


PHP Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /var/www/html/index.php on line 371



Any ideas on what I should try next?

Comments

  • HI eswbitto,

    Gibbon v18.0.01 requires PHP version 7.0 or above. It looks like you are running PHP 5.4.16, which would cause the errors you're seeing.

    Hope this helps!
    admin
  • @sandra

    Thank you, I updated to 7.3 and I can now see an installation webpage.

    I get the following error....

    The directory containing the Gibbon files is not currently writable, or config.php already exists in the root folder and is not empty or is not writable, so the installer cannot proceed.

    So I've changed the webroot to both 755 and 777 and verified the config file is not there. I'm fresh out of ideas on what to do.
  • Hi eswbitto, this is an odd situation. One possibility, "root" can mean the document root for the whole web server, or the root of the Gibbon file structure. If you installed Gibbon in the document root (rather than in a subfolder), this would not apply...but I wonder if you are looking for config.php in the document root, but it is actually in the Gibbon root. Cheers, Ross.
  • @admin

    Thanks Ross,

    To give an update I made some changes on the server and now I can get to the installation screen where it does the check on system requirements. The weird thing now is it is showing some of the PHP extensions as not being installed. Which is odd because, I've verified these extensions are indeed installed. I'll post more information if I can't figure this one out on my own.

  • Update:

    I finally have it working. I had to disable the remi repository for php 5.4 and enable to 7.3 and then install the php extensions. Thank you for the help!
  • Excellent news. Thanks for keeping us up dated as to the eventual fix : )
Sign In or Register to comment.