Cannot install error "Your request failed because you do not have access to this action."

Comments

  • I have exact same problem

    .... HELP
  • Hello! One reason this happens is that you use the back button in your browser, which causes issues for the installer. Can you remove /config.php and start the installer again. Hopefully this solves the issue. Thanks! Ross.
  • Thank you Ross.
    Where is config.php file?
  • Windows version
  • You will find it in the main folder, where you also have login.php, gibbon.php and notifications.php :)
  • Hi aimar64, interesting! We don't have a lot of Windows experience in the core team, and so I'd be keen to find out what this issue is eventually. The folder Roman is refering to (thanks @meierrom!) is what we call the absolutePath, or the base installation folder for Gibbon. As a short hand, we tend to refer to this as /, in the Posix tradition. Thanks, Ross.

  • Thank you meierrom and Ross.
    I can't find that file on root folder and I search for config.php file but nothing found.

  • My experiences running a server on Windows are not good. Things worked much better once I switched to Linux.

    I would recommend installing virtualBox with either opensuse debian or ubuntu.
    adminaimar64
  • You are looking in the right location, but I can't see config.php. On reflection, this makes sense, as it is only created at the end of Step 2, and so where your error is occurring, it would not have been created yet. Ross.
    aimar64
  • You should be able to find hints on the issue by checking your apache and php logs tho :)
  • I found how to solved that problem
    I can config but I can't login

  • I think the cause of the commented-out section not working is the same as the login not working. It seems that you have an underlying issue with session data in your install. I would do some research into Windows PHP servers and sessions and see if there is a configuration option in your PHP server that is impacting this. Good luck! Ross.
  • Thank you Ross.
    admin
  • Can you help me Ross?
  • Hello again aimar64. Did you have any luck troubleshooting sessions in Windows? If not, let me know where you are stuck..but Google will give much better answers than I can, as I don't know Windows server well. Ross.
  • I'm sorry to bother you.
    I stuck on login page I click the login button, and nothing happens.
    Can you help me to find debug point, I will try it.
  • Can you have a look at your apache and php logs?
    admin
  • no any log from iis and php
  • I believe this must be session related. Try the advice given here:

    https://forums.iis.net/t/1149807.aspx

    Ross
  • admin said:

    I believe this must be session related. Try the advice given here:

    https://forums.iis.net/t/1149807.aspx

    Ross

    Thanks for your advice, but still no luck I cannot log in. Folder session can fully control with everyone, and I attach sessions file for problem analysis.
  • Interesting. Are you able to run other PHP apps on this server? For example, what happens when you install WordPress. Do you see similar behaviour?
  • Yes, I can install and login to WordPress. I was curious about what it caused. I install Gibbon in any VM or host with windows server it same result.
  • Dear Team,

    Did you find solution for this...

    I have tried installing multiple Gibbon in same Linux server on multiple subdomains, I managed the first two but stuck with this same error on the next two subdomains.

    I've tried checking most common reasons: config file + server sessions and error logs + googling and no success.

    The subdomains are supposed to serve different sections/ levels of the same school.


    Regards
    Kelvin
  • Hi Kelvin,

    This error most often shows up if the page is refreshed during the installation process. If this is not the case, then it may also show up if PHP doesn't have access to properly write to the session. Were all the checkmarks green in your installation screen?

    It may also happen if you have installed these subdomains in sub-folders of the same server, if that server has a redirect or other htaccess rewrites on the base-level of the domain. Redirects can often interfere with posting form data from one page to the next. This can often be fixed by setting the base-level htaccess file to ignore the subfolders, see the example here: https://ask.gibbonedu.org/discussion/comment/3456#Comment_3456

    Hope this helps!
Sign In or Register to comment.