Cant set any language besides english, on Windows 10.

Hello, first thanks for all the work that went into this sytem.

I had 16.0.1 running on Windows 10, running on XAMPP, i didn't have any problems with the system until a windows update reboot, Gibbon was set to Spanish but since then its on English and none of the on system tools translate it, tried 17.0.1 and its the same.

i checked that my Windows 10 region locale is set to Spanish, tried with different browsers, and updated XAMPP, reinstalled the system specifying Spanish, installed the hole thing on another updated Windows 10 machine and nothing has worked.

None of the XAMPP logs reveal an error.

Anyone has an idea of what has caused this? any help would be greatly appreciated.
Thank you.

Comments

  • Hi Luchin57,

    It certainly sounds like the system locale is no longer being detected by Gibbon, and looks like you've already done a lot of great troubleshooting. I haven't worked with XAMPP personally, wish I could offer some specific help! In the PHP docs for setlocale there is a note about Windows systems that setting the locale to setlocale(LC_ALL, '') may default it to the system region settings. To test this theory, you could edit the src/Gibbon/Locale.php script and replace the setlocale call on lines 71-75 with setlocale(LC_ALL, '') and see if it helps.
  • thx for the help, in this mean time i tried reinstalling windows 10, worked at first but then an update lock it to English again, today it downloaded another update and now is fully working in any language. guess just microsoft things.

    im using Ubuntu now.
  • i was wrong, it works only in Spanish now, even on ubuntu, there are no other languages for choosing, even if you install it in English works only in Spanish.
  • sry for the triple post, i don't know to edit my prev posts.

    the problem doesn't exist in 16.0.01, there i can install in English and set it to Spanish later and vice-versa.

  • Hello,
    I have the same issue on Windows 10
    Gibbon Installation with xamp in Windows 10 English
    Language setting in French
    Il still show gibbon in English

    I tried to chance php code like in the picture below whithout success in the file src/Gibbon/Locale.php

    Please Help






  • Mine now works fine and i haven't changed anything, update windows?
  • I want to confirm this solution for an installation in xampp
    sandra said:

    Hi Luchin57,

    It certainly sounds like the system locale is no longer being detected by Gibbon, and looks like you've already done a lot of great troubleshooting. I haven't worked with XAMPP personally, wish I could offer some specific help! In the PHP docs for setlocale there is a note about Windows systems that setting the locale to setlocale(LC_ALL, '') may default it to the system region settings. To test this theory, you could edit the src/Gibbon/Locale.php script and replace the setlocale call on lines 71-75 with setlocale(LC_ALL, '') and see if it helps.

  • but now I can´t change it again to english
  • It sounds like on Windows systems using the setlocale(LC_ALL, '') modification may default Gibbon to use the current system's region settings. In this case, it may not allow for switching between languages, but sticks to whatever the system is currently set to. I'm not familiar with this particular Windows setup though, it sounds like @Luchin57 may have had some luck with updating their system, and it worked after that?
  • I am in linux and i can't change the language, is a fresh install but i can't change the language, ¿what could be happening?
  • Hi uebmaster,

    On linux, the most common cause of not being able to switch languages is the locale hasn't been installed. There's more info in the docs here: https://docs.gibbonedu.org/administrators/misc/internationalisation/ For example, to install Great Britain English under Ubuntu you would run the command: sudo locale-gen en_GB
    meierrom
Sign In or Register to comment.