supported php version for Gibbon

I have been following this project for a while now and at the moment I have a working install howto for NethServer (www.nethserver.org)
I do have a question: The current install isntructions for Gibbon point to php5.5 as the version to be installed. php5.5 is deprecated and 5.6 will be deprecated as of jan 1st 2019. see http://php.net/supported-versions.php
Will Gibbon support php7.x or is it in the works to get it supported?

Comments

  • Hi Robb, Gibbon v16 will run on anything higher than 5.5, as far as we know. The currently-in-development v17, due out on January 20th, it will require php7 or greater. Cheers, Ross.
  • Thanks for the swift response! Good to hear deprecated packages are not mandatory.
    Would it be a good idea to not allow deprecated php versions? Or would that break existing installs?
  • I just tested to install gibbon 16.0.0.1 with php7.1 and that works like a charm....
    admin
  • Hi Robb,

    Yes, I guess for security reasons we could set a control on the lowest acceptable PHP version. Up until now that is not something that has come up as an issue, and so we've not done it.

    One risk in doing so would be, as you say, breaking old installs. Another would be encouraging old installs admins to keep running old server software on their stack, which could undo the security gains of running newer versions of PHP.

    Might leave it for now and see if it becomes an issue.

    Cheers,

    Ross
  • Maybe add a warning banner that the version of php is outdated and urge to upgrade (preferably with a link to instructions to do so)
    admin
Sign In or Register to comment.