online form is taking too much time to submit

Dear Support,

I have installed gibbonv15 in virtualbox and it is running successfully

But when I try to submit the online form from the

It is taking too much time to submit.

please help me to proceed for quick submission.


  • Hello, this is interesting, as this form should take not much longer than any others: it is a long form, but it is not doing anything crazy on the backend. I wonder if you can check your PHP logs to see if there are any errors or warnings? Another option is to try and comment out various sections of the form process script to see where it is sticking. What PHP version are you using? What OS? Thanks, Ross.
  • I am using OS

    Ubuntu 14.04.5 LTS (GNU/Linux 4.4.0-31-generic x86_64)

    PHP Version

    gibbon@gibbon:~$ php -v
    PHP (cli) (built: Feb 6 2018 16:35:00) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache, Copyright (c) 1999-2018, by Zend Technologies

  • Hmmm, we've not tested a lot with PHP 7.2. Could you try a earlier version, such as 7.1.x and see if they helps? Did you check the PHP error log?
  • When I entered the command

    php -v it is showing

    PHP 7.2.3-1+ubuntu14.04.1+deb

    in it is showing

    PHP Version 5.5.9-1ubuntu4.23

    Which one we have to consider?
  • The second one should be accurate. The first one is most likely the command line version. 5.5.9 should work for Gibbon, but you could try and update it to 7.x to see if it makes a difference.
  • I wonder if the application form taking longer than most might be related to a slow connection from PHP to the mail server. Most forms don't send emails, but depending on your configuration it could be sending several (one to the parent, one or more to admissions, optionally to referees or with payment details). If you send an email through the messenger does it also seem to take a bit longer than the average form?
  • Guys,

    How to resolve it?

  • Try Sandra's test, and use Messenger to send a message to a few users, and see if that takes longer than expected to send. Let us know the result of this test.
  • Yes, Without the SMTP settings enabled, it is working.

    So what to do if I would like to enable mail settings
  • Well deduced on Sandra's part! What can you tell us about the SMTP server you have used? Is it local or near to the Gibbon machine? Is it on a fast network? Is it overloaded?
  • We are using google mail service.
  • We use google mail too and it is a bit slower than local mail. Using an external service will tend to slow things down as it makes a round-trip to an outside server. We did find that switching from the setting to using appeared to speed things up, where the send time was 1-2 seconds. If you're not already using this setting it may be worth updating.

    The details can be found here:

    Hope this helps!
  • It is 20 seconds while using smtp-relay gmail

    Is there any other way to reduce this time?
  • You could try and set up your own SMTP server, either locally on your web server, or on another nearby machine. Possible?
Sign In or Register to comment.