Smart Workflow Tab

Hi all i seem to have lost my Smart Workflow tab on the home page ? is there any way to get it back up i think i press the dismiss link on the bottom right corner and now i cant figure out how to get it back.

thanks orlando

Comments

  • Orlando, once it is gone, the only way to get it back is in your database. Try and run the following SQL using a database client (e.g. phpMyAdmin, DBeaver, etc), just make sure to replace the username admin with your own username:

    UPDATE gibbonStaff
    JOIN gibbonPerson ON (gibbonStaff.gibbonPersonID=gibbonPerson.gibbonPersonID)
    SET smartWorkflowHelp='Y'
    WHERE username='admin';

    Thanks,

    Ross
  • Oh boy thanks for your reply i will give it a go and let you know thanks
  • Hi thank you got it working now your advise above work a charm its good to know how to fix that problem in case a staff member makes the same mistake.
    admin
  • Excellent. The aim is that, and our experience backs this up, people leave it there for a while, learn from it, and then dismiss it and rarely ask for it back. If it becomes a common thing, let us know, and we will add it as a field to the Manage Staff section. Ross.
  • I have the same problem, Smart Workflow does not appear anymore. I tryed your suggestion Ross, I used phpMyAdmin, the in the SQL I copied and pasted this:
    UPDATE gibbonStaff
    JOIN gibbonPerson ON (gibbonStaff.gibbonPersonID=gibbonPerson.gibbonPersonID)
    SET smartWorkflowHelp='Y'
    WHERE username='myusername';

    I got the following results from SQL:

    1 row affected. (La consulta tardó 0.0005 seg)
    UPDATE gibbonStaff JOIN gibbonPerson ON ( gibbonStaff.gibbonPersonID = gibbonPerson.gibbonPersonID ) SET smartWorkflowHelp = 'Y' WHERE username = 'myusername'

    In the last line I replaced admin by my username, but I don´t see the Smart Workflow for the first log in, I logged in the fisst time with different users and nothing.
  • Ross, once I entered to MY account I realized I can see the smart workflow, but not in other user accounts. What should I do to make it available for all teachers?, in one, two or three steps please, !!!!
  • edited March 2017
    Adolfo, it should appear for any staff who are registered under People > Staff > Manage Staff. They will see it until they press the Dismiss link in the Smart Workflow Help dialogue. Hope this helps : ) Ross.
  • Noup. it doesnt appear, this is a capture for one user that logins first time:



    By the way, there is no any "Submit" button once a new user loggins !!! (that was your suggestion)
    I have to perform the SQL process for each user (one by one) to make the Smart Workflow appear !!
  • Sorry, not Submit...Dismiss! I meant the Dismiss link on the Smart Workflow help. I'll edit above to clarify.

    Can you verify the value of the smartWorkflowHelp field for the staff member in question, in the gibbonStaff table in your database?

    Ross
  • I'm moving this way: GibbonStaff > Structure > smartWorkflowHelp, look:



    Seems to everything is ok because under Predeterminado (Default) says "Y", am I wright?
    I´m little bit confused because you say I have to check the smartWorkflowHelp field for the staff member in question, and I need to this value to be Y for all. Thanks Ross
  • At the moment you are looking at the structure of the table, not the contents. Click on the Examinar (Browse in the English version of phpMyAdmin) and you will see records for each of your staff. Can you find the relevant person in there or using Buscar (Search) on their gibbonPersonID?
  • Ok, now I´m checking the Browse option and look:


    Just me and another teacher have the "Y" under the smartWorkflowHelp column, and I need everybody to have it enabled. Just to mention that teachers are not accessing Gibbon yet, does the Smart WorkFlow switches to Y once they loggin the first time?. I have been trying their usernames and passwords and the smart workflow is not available yet!!
  • If you are using v12, this is a bug, and it was fixed in v13. The bug is that new staff, when they are created, get smartWorkflowHelp='N', even thought default is 'Y'.

    You can fix the current accounts with the following SQL:

    UPDATE gibbonStaff set smartWorkflowHelp='Y';

    But new staff will need to be fixed each time someone is added.

    Best bet is to upgrade to v13.

    Ross
  • Thanks Ross, I´m using version 13 right now !!! :'( The problem continues.
  • OK, but staff created under v12 will still be affected unless you run the SQL above. Have you tried doing that? Ross.
Sign In or Register to comment.