allow_url_fopen == 1 won't work

Hi all I have updated to v21.0.01 in my System Check I am getting X on allow_url_fopen == 1 and don't understand why as in my php.ini i have setup allow_url_fopen = On.
I have also add php_value allow_url_fopen On in my .htaccess still with no luck can anyone help me with this problem ?
I am using php74.

Thanks Orlando

Comments

  • orlando said:

    Hi all I have updated to v21.0.01 in my System Check I am getting X on allow_url_fopen == 1 and don't understand why as in my php.ini i have setup allow_url_fopen = On.
    I have also add php_value allow_url_fopen On in my .htaccess still with no luck can anyone help me with this problem ?
    I am using php74.

    PS when anyone is adding Behaviour Records the site once they submit it just hangs user would have to close browser and reopen the Behaviour Record is saved but each time this happens and I think its because allow_url_fopen == 1 is not working.

    Thanks Orlando

  • edited March 12
    Hi Orlando, that is interesting. After updating php.ini have you restarted your web server (e.g. Apache or nginx) process? That needs to be done for the settings to be updated. You can use phpinfo, which Gibbon v21 makes available under Admin > System Admin > Server Info to see if it really is enabled.

    I don't believe the Behaviour Records issue would be related to this (although it might!) as this is allows Gibbon to treat remote files like local files...and Behaviour does not use any external files in this way. Best thing here would be to check your Apache access and PHP error logs, and use to use Inspect Element (in your browser) to check the Network tab in order to see on what file things are getting hung up.

    When you say it "hangs" is it still loading, or does it load a blank page? The former suggests network error, the latter a PHP error.

    Let us know how you get on.

    Ross
  • HI Ross

    Thanks for getting back to me when you say it "hangs" I mean it is still loading takes about 2 mins or so then I get (( Your request was completed successfully)) so a long time. I have also done a full reboot of the server with no changes, will check my PHP error logs to see if it shows the problem.
  • Hi Ross

    Had look at my error logs this is what i found.

    [11-Mar-2021 13:41:11 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'ixed.5.4.lin' (tried: /opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ixed.5.4.lin (/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ixed.5.4.lin: cannot open shared object file: No such file or directory), /opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ixed.5.4.lin.so (/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ixed.5.4.lin.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
  • Are you using php v5.4? I doubt this can work well with Gibbon. The current minimum requirement is v7 afaik. ;)
  • no i am using PHP Version ea-php74 don't know why the error log is showing this ?
  • looking at my php.ini looks like the problems are in there, but not sure what i need to do to update the information in the file.
    Things like
    ; Directory in which the loadable extensions (modules) reside.
    ;extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20060613"
    zend_extension="/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ioncube_loader_lin_5.4.so"

    extension_dir = "/opt/php54/lib/php/extensions/no-debug-non-zts-20100525"
    ; Whether or not to enable the dl() function. The dl() function does NOT work
    ; properly in multithreaded servers, such as IIS or Zeus, and is automatically
    ; disabled on them.

    ;zend_loader.enable=1
    ; Disable license checks (for performance reasons)
    ;zend_loader.disable_licensing=0
    ; The Obfuscation level supported by Zend Guard Loader. The levels are detailed in the official Zend Guard Documentation. 0 - no obfuscation is enabled
    ;zend_loader.obfuscation_level_support=3
    zend_extension = "/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ZendGuardLoader.so"

    These look wrong to me ?
  • Yep, looks like you have some really old stuff hanging in there. ;)

    Seems not really a Gibbon issue to me. Maybe doing some research in other forums related to ioncube configurations?
  • Hi Orlando, Roman's observation is very interesting. I know that Ubuntu Linux, for example, can have different PHP versions for command line and web server, and so perhaps you are looking at the wrong log?

    The long hang time could be related to a network issue, or to something on the PHP side. More investigation needed to narrow that down.

    Cheers,

    Ross
  • Hi all

    I have managed to fix the problems Meierrom was right had to do some changes in CPANEL in regards to (( zend_extension ))
    I also noticed upgrading Gibbons over the years that i did not remove all folders from pervious versions this has caused some of the problems as well so did a fresh install and moved my database over and all is good again.
    Now showing PHP Version ea-php74 as it should I am still having problems with allow_url_fopen == 1 not working still doing checks on this, once I have found the problem will update this post.

    Thanks for all your help with this matter Ross and Roman
    meierrom
  • Hi Orlando, great to hear you've made progress. I wonder if you look for allow_url_fopen under the System Admin > Server Info (available in v21), rather than the System Check, if you'll be able to see the exact value for this setting.
  • Hi Sandra

    Had a look at System Admin > Server Info and its showing as off as well please see below so for sure


  • I am still doing checks to find what the problems might be.


  • Hi Orlando, as you refer to cPanel, I guess this is on a hosted server? Checking with your host's support team might be a good way to go, as sometimes hosts restrict changing such settings. Cheers, Ross.
    orlando
  • Hi all managed to fix the issue thanks Ross the problem was within Cpanel for anyone having this problem now or in the future please see the link below
    https://chemicloud.com/kb/article/how-to-enable-or-disable-allow_url_fopen-in-cpanel/
    admin
Sign In or Register to comment.