Getting Fatal Error at the time of installing

Hello,
I am trying to install the software on my local machine. But while installing got bellow error after submitting database information at step-2 of installation.

Fatal error: Declaration of PDOStatement::fetch(int $mode = PDO::FETCH_BOTH, int $cursorOrientation = PDO::FETCH_ORI_NEXT, int $cursorOffset = 0) must be compatible with Gibbon\Contracts\Database\Result::fetch($fetch_style = null, $cursor_orientation = null, $cursor_offset = null) in C:\xampp\htdocs\core\src\Database\Result.php on line 0

I downloaded the latest jar from the website and followed the steps mentioned in installation guide.

I tried searching for the solution on many websites but could not resolve issue.
Can anyone suggest how to resolve the error?

Thank you.

Comments

  • Hi Harsh,

    I'm sorry to hear that you are having problems with this. Can you please confirm the version of PHP and MySQL on your server?

    Thanks,

    Ross
  • Hi Ross,
    I have PHP version 8.0.0 and MySql version 8.0.17.

    Thank you for looking into this.
  • Hi Harsh,

    I believe this issue may be linked to PHP8, which we've not done a lot of testing with.

    Let me check with @sandra (Gibbon's Maintainer) to see what she says.

    In the meantime, if you can try with PHP7 I'd be interested to see if that resolves this issue.

    Hi Sandra,

    Where do we stand on PHP8 compatibility?

    Thanks : D

    Ross
    harshpatil89
  • Since PHP 8 is so new, released Nov 26, 2020, we don't have support for it in v21.0.00. We can work on support for it in future versions, but for now the highest version that Gibbon supports is PHP 7.4.

    Thanks!
    admin
Sign In or Register to comment.