Moodle- Gibbon Integration Login problems

I am running Moodle 3.8.3 and Gibbon Core 20 on the same shared Domain Server Running PHP 7.1 to 7.4 and MariaDB 5.6. Moodle files are on the sub-domain while Gibbon is on the main domain. The systems were running quite okay separately but now I activated the external database enrolment and authentication plugins in Moodle and hell has broken loose. Nobody is able to log into MOODLE as it is failing with "Ëxception - Call to undefined function msql_connect()" error.

But we are able to log into the Gibbon system without any problems except the integration is not there yet done.

I have tried to follow some instructions about changing enrol_database dbtype and auth_db type in the mdl_config_plugins moodle variables to msqli for both values but still not working.

Is there any workable solution to this problem? Or how can I reverse these changes manually since I cannot login into MOODLE even as the Administrator?

I am only able to get into the Moodle system files using cPanel.
Your prompt assistance will be most appreciated.

Raphael

Comments

  • Have you tried uninstalling the plugin from Gibbon (Moodle plugin) and confirming the config file in Moodle is linked to the correct database (initial DB before the integration)?
  • kelvinmw said:

    Have you tried uninstalling the plugin from Gibbon (Moodle plugin) and confirming the config file in Moodle is linked to the correct database (initial DB before the integration)?

    No, I haven't tried to uninstall the plugin from Gibbon (Moodle plugin) because I want the integration to work. What next if I uninstall the Moodle plugin?
    Kind regards
    Raphael
  • Hi Raphael, I wish I could help but Moodle isn't my area of expertise :sweat_smile:

    @leofreitas Perhaps you might have some suggestions? Thanks!
  • Hi Raphael,
    Raphael, if you have access to the database, check the field auth in the table user. Change field auth to 'manual' for all users.
    Best regards
    admin
Sign In or Register to comment.