Gibbon v20 & MySQL 8

MySQL has recently made a significant jump, from v5 to v8. On the surface, Gibbon v20 works well with MySQL 8. However, more thorough testing has shown that a number of issues do exist, which leads us to recommend avoiding MySQL 8 until the release of Gibbon v21 (January 20th 2021). By this time, we hope to have ironed out all related issues.

One wrinkle is that the latest version of Ubuntu Linux (which we general use to host our Gibbon installs), Ubuntu 20.04, comes with MySQL 8 by default. If you install this latest version of Ubuntu, we advise downgrading to MySQL 5.

Please let us know here if you find any MySQL 8 issues, and we'll rectify them in the Gibbon v21 branch.

Thanks!

Ross
ub123kelvinmwChellie

Comments

  • Ross, our hosting service uses MariaDB version 10.0.38. Since the version numbers are so different, I searched for an equivalency list and found one on the MariaDB.org site and thought it might be helpful to others. Am I correct that all of the MySQL 5.x releases would be OK for Gibbon? If so, then all of the MariaDB versions up to 10.2 should be OK. Here are the comparisons I found:
    "MariaDB 10.2, MariaDB 10.3, and MariaDB 10.4 function as limited drop-in replacements for MySQL 5.7, as far as InnoDB is concerned. However, the implementation differences continue to grow in each new MariaDB version.
    MariaDB 10.0 and MariaDB 10.1 function as limited drop-in replacements for MySQL 5.6, as far as InnoDB is concerned. However, there are some implementation differences in some features.
    MariaDB 5.5 functions as a drop-in replacement for MySQL 5.5.
    MariaDB 5.1, MariaDB 5.2, and MariaDB 5.3 function as drop-in replacements for MySQL 5.1."
    sandra
  • Hi Glenn, thanks for sharing this...it is a shame the version numbers don't line up!

    MySQL 5.x ought to be OK for any recent version of Gibbon. There are definitely minimum versions for PHP, but less so for MySQL.

    Cheers,

    Ross
Sign In or Register to comment.