Help My Icons have all gone missing

Hi team on my hosting I had asked some changes to be done to increase the max upload limit for my moodle but when i log into gibbons i noticed all the icons missing. can someone please tell me what should be the correct settings in php.ini or any other page. All icons seem the be missing in all pages. Listed below is an image. I tried clearing the cache but still the same.

Comments

  • Hi paschal,

    The icons are located in the themes/Default/img folder from your Gibbon root directory. Perhaps double-check that they are there, and the system still has read-access to them (0644 or 0755 file permissions). Otherwise, it may be something in your system that is preventing access to them. If you navigate to an image manually can you see it in your browser? Try your Gibbon URL + /themes/Default/img/planner.png

    Hope this helps!
  • Hi Sandra,
    Thanks for the quick response. I browsed through the file manager in the root directory and checked for the images. I Could view them on the browser and the permission for folder is 755 and permission for images in folder are 644. even when i do the system check the icons with a tick and cross does not load but on mouseover i check all are yes. Have some of the files got corrupt?. Background image loads and now the images planner and attendance.png is loading after I made changes from php version 7.0 to to 7.2. but all the other images/icons do not appear. Is there any way i can only download the image folder and replace it.
    If I have to reinstall gibbons is there any way transfer timetable, users, special days, etc without having to do it again. Is there the theme available for download so I can reinstall it.


    Thanks in advance.
    Paschal
  • Hi Paschal,

    No worries, I don't think you'll need to reinstall, it's likely a system setting or maybe an http redirect somewhere. The next step to check may be that the Base URL in your SystemSettings is correct (if you use HTTPS, is there an s in the Base URL?) and then look to see if you have any settings in your .htaccess file that may be redirecting or preventing access to png files.
  • I guess as I had installed SSL certificate to the site when I was upgrading my moodle to the latest version which required ssl. My gibbons base url is http not https. Is there a config file where I can make changes so my gibbons base url also becomes https.

    I did a refresh in browser and now all images are not loading. :/ even the background
  • If you update the Base URL in System Admin > System Settings to add an s this should work, then you may need to clear cache on your browser to ensure that all pages and templates are using the new https:// url.
  • I made the changes and get an error
    Misdirected Request

    The client needs a new connection for this request as the requested host name does not match the Server Name Indication (SNI) in use for this connection.
  • Hmmm. Is it possible the SSL certificate is specific only to a moodle subdomain and not a gibbon one? (if you're using subdomains). Otherwise, it sounds like you're on the right track, there must be a setting or redirect somewhere that's causing this. For now, you could take the s back out of your Base URL (so that the images in Gibbon don't appear broken).
  • I did remove the s from the base url and now only the site loads normally only the images not loading. I shall keep this running for the time being and see if I can move gibbons on a different hosting to avoid inconvenience to the users. Do you recommend https for version 18.

    I checked for redirects on the cpanel and there are no redirects shown.
    Thanks a lot sandra for your quick respone. I am indeed grateful for your support.
  • Do you recommend or suggest that I uninstall the ssl certificate on my gibbons installation.
  • Hi Sandra
    I dont know if I did the right thing. When i checked Cpanel hotlink protection I saw block direct access to jpg,jpeg,gif,png,bmp. I removed the extensions I enabled hotlink protection in the Cpanel and then all images/icons reappeared.
    Well I dont know if this is safe and can cause any problems. Advise please.
    Thanks in advance.
  • Hi paschal,

    Yep, that sounds like the type of system setting that would cause your error, sounds like you've solved the mystery! Hotlink protection tends to be useful for things like blogs and websites where you don't want other websites re-using your images and media. In this case, you should be safe. One option might be to add pdf to the hotlink list but keep png and jpg out of it, this can help protect any documents that are uploaded (which are already obfuscated in the upload process too).
  • Thanks Sandra for that info and thanks for taking the time and helping me out. I am so glad i am using Gibbonedu and have such wonderful people who help out. Kudos Gibbonedu family.
    sandra
Sign In or Register to comment.